Degradation of Service
Incident Report for MediRecords
Resolved
Hi,

Our team have been able to successfully resolve this and normal service has resumed.

We thank your for your patience. Any questions, please don't hesitate to contact us on 1300 103 903 or email support@medirecords.com.

Kind regards,
Your MediRecords Support Team
Posted Oct 18, 2019 - 15:46 AEDT
Investigating
Hi,

MediRecords is currently experience slight degradation of service. Some of you may be experiencing slow response times. We apologise for any inconvenience this may cause. Please be assured our team are working on a solution now.

Kind regards,
Your MediRecords Support Team
Posted Oct 18, 2019 - 15:33 AEDT
This incident affected: MediRecords.