Medicare Performance Degradatation
Incident Report for MediRecords
Resolved
This incident has now been resolved. Please resume all Medicare activity at your convenience.
Posted Jun 09, 2021 - 20:03 AEST
Identified
The Department of Human Services are currently investigating issues that may impact users sending claims, performing OPVs and other functions. MediRecords will update if additional information from the Department of Human Services becomes available.
Posted Jun 09, 2021 - 14:55 AEST
This incident affected: Third Party Components (Medicare).