My Health Record update
Incident Report for MediRecords
Resolved
We have finished the update to My Health Record. You will now be able to upload summaries as per usual.
Posted Mar 06, 2019 - 13:15 AEDT
Update
We are continuing to monitor for any further issues.
Posted Feb 20, 2019 - 17:13 AEDT
Monitoring
MediRecords is undergoing a My Health Record update. You will still be able to retrieve information from and view a patient's MHR, however uploads will not be available until the update has been completed.
Posted Feb 11, 2019 - 11:39 AEDT
This incident affected: MediRecords.