Error messages in MediRecords
Incident Report for MediRecords
Resolved
This incident has been resolved.
Posted Sep 13, 2022 - 09:49 AEST
Investigating
Some users are experiencing error messages and general degraded performance when using MediRecords. We're currently investigating this with high priority.
Posted Sep 13, 2022 - 09:32 AEST
This incident affected: MediRecords.