Performance Degradation

Incident Report for MediRecords

Resolved

MediRecords is fully operational again. We thank you for your patience and apologise to affected customers for any inconvience this may have caused you.

Any questions, please don't hesitate to contact us on 1300 103 903 or email support@medirecords.com.

Kind regards,
Your MediRecords Support Team
Posted Oct 31, 2019 - 18:27 AEDT

Monitoring

Good evening all,

Our development team is currently looking into a number of reports of slow performance of MediRecords. We will provide updates as they become available.

Kind regards,
The MediRecords Support
Posted Oct 31, 2019 - 16:58 AEDT
This incident affected: MediRecords.