Appointment Scheduling Issues in MediRecords

Incident Report for MediRecords

Resolved

The issue has now been resolved, as the issue had impacted appointments we encourage any impacted users to review all appointments that was updated or created today to ensure the changes are reflected. If you have any further issues please contact our Support team.
Posted Apr 09, 2026 - 20:44 AEST

Update

The Medirecords team continues to actively work on resolving the current appointment booking issue. We are monitoring the fix that was deployed and there maybe still some residual issues which are being investigated.

Our teams are continuing investigations and remediation efforts to restore full service as quickly as possible. We appreciate your patience while this work continues.
Posted Apr 09, 2026 - 14:52 AEST

Update

The Medirecords team are continuing to work actively on a solution to remediate the current appointment booking issue.

Description of Impact - a series of unavailable appointment slots being created when Day Light Savings are OFF, the unavailable slots that are set for the month with Day Light Savings do not automatically adjust in the calendar to the changed time. Users are required to manually change the unavailable slots.

We appreciate your patience and understanding while this work is completed.
Posted Apr 09, 2026 - 13:19 AEST

Investigating

We are currently aware of an issue affecting appointment scheduling within MediRecords.
Some clinics are experiencing appointments being automatically moved, resulting in overlapping bookings. In addition, any manual adjustments made to appointments may revert back after refreshing the system.

Our team is actively investigating this issue as a matter of urgency and working to identify the root cause.
We understand the significant impact this is having on clinic operations and sincerely apologise for the disruption caused.
We will provide further updates as more information becomes available.

Thank you for your patience and understanding.
Posted Apr 09, 2026 - 09:07 AEST
This incident affected: Appointment Book.