Degraded Performance

Incident Report for MediRecords

Resolved

This incident has been resolved
Posted May 19, 2023 - 14:56 AEST

Investigating

We are currently investigating
Posted May 19, 2023 - 12:12 AEST
This incident affected: MediRecords.