Degraded Performance

Incident Report for MediRecords

Resolved

This incident is resolved.
Posted May 19, 2023 - 18:22 AEST

Investigating

We are currently investigating.
Posted May 19, 2023 - 16:03 AEST
This incident affected: MediRecords.