Services Australia System Degradation

Incident Report for MediRecords

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 17:18 AEST

Monitoring

Services Australia is currently experiencing degraded performance. We are aware users are unable validate IHI numbers, preventing users from accessing My Health Record, ePrescribing, Medicare and AIR Claiming.

We’ve identified that this issue originates from our third-party supplier, Services Australia. While the root cause lies outside of our systems, we are working closely continuing to monitor the situation to ensure timely resolution and have reported the issue directly to Services Australia.

We will provide updates as we receive further information from Services Australia.
Posted Apr 24, 2026 - 14:02 AEST

Update

We are continuing to investigate this issue.
Posted Apr 24, 2026 - 13:36 AEST

Update

We are continuing to investigate this issue.
Posted Apr 24, 2026 - 13:33 AEST

Investigating

Services Australia is currently experiencing degraded performance. We are aware users are unable validate IHI numbers, preventing users from accessing My Health Record, ePrescribing and Medicar Claiming.

We’ve identified that this issue originates from our third-party supplier, Services Australia. While the root cause lies outside of our systems, we are working closely continuing to monitor the situation to ensure timely resolution and have reported the issue directly to Services Australia.

We will provide updates as we receive further information from Services Australia.
Posted Apr 24, 2026 - 12:21 AEST
This incident affected: Claiming Services (Medicare, Australian Immunisation Register (AIR)), Australian Digital Health Agency Services (My Health Record, Health Identifier Service (IHI Validator)), and ePrescribing and Prescribing.