Unable to register patient using the MediRecords Widget due to "you have entered an incorrect address" error in the address field.

Incident Report for MediRecords

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 28, 2026 - 18:03 AEST

Investigating

There is an issue with new patients attempting to sign up using the Appointment Widget. The address lookup feature is currently broken, intermittently preventing booking of a new appointment.

This issue was first reported at midday today, the MR teams are investigating and working on a solution.
Posted Apr 28, 2026 - 15:47 AEST
This incident affects: Appointment Widget.