Cannot load documents on My Health Record

Incident Report for MediRecords

Resolved

ADHA advised the issue is now resolved with services restored.
Posted May 19, 2026 - 15:12 AEST

Identified

Service Australia have advised there is currently an MHR degradation issue to their service. Their Agency is working to resolve the problem.
Posted May 19, 2026 - 10:17 AEST

Investigating

Impact: Some customers are unable to prescribe without checking the active medication of the patient. Impacts My Health Record.

Current Status: Medirecords are currently investigating the issue and liaising with providers. We will provide an update accordingly.

Workaround - Providers can log in to the National Provider Portal using a PRODA Account
Posted May 19, 2026 - 10:04 AEST
This incident affected: Australian Digital Health Agency Services (My Health Record).