System Degredation
Incident Report for MediRecords
Resolved
This incident has been resolved. We appreciate your patience
Posted Nov 17, 2022 - 19:20 AEDT
Investigating
We are aware of a system-wide event causing errors and login issues. We are investigating the cause with urgency and will update this status shortly
Posted Nov 17, 2022 - 19:13 AEDT
This incident affected: MediRecords.