[ ] Experiencing Degraded Performance
Incident Report for MediRecords
Resolved
This incident has been resolved.
Posted Oct 22, 2024 - 11:18 AEDT
Update
We are continuing to investigate this issue.
Posted Oct 21, 2024 - 12:18 AEDT
Investigating
Users are currently experiencing System slowness and overall degradation of the platform. We are working diligently to return the system to normal functioning. Please continue to monitor this page for any updates as well as reaching out to Support if you require further assistance.

We appreciate your patience during this incident.
Posted Oct 21, 2024 - 12:18 AEDT
This incident affected: MediRecords.