Degraded Performance
Incident Report for MediRecords
Resolved
We have implemented a fix and MediRecords should be functioning normally. Please contact Support if you are continuing to have any issues.
Posted May 22, 2023 - 10:26 AEST
Update
Some Customers are still experiencing degraded performance. We are continually monitoring the system and working to improve performance.
Posted May 22, 2023 - 09:01 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 20, 2023 - 17:51 AEST
Investigating
We are currently Investigating
Posted May 20, 2023 - 16:55 AEST
This incident affected: MediRecords.