Intermittent Appointment Calendar Slowness & Degradation

Incident Report for MediRecords

Resolved

Thank you for your patience while we investigated the appointment slowness problem. Based on our monitoring, the issue now appears to be fully resolved. Please reach out to our support team if you are still experiencing any issues.
Posted Jan 20, 2026 - 14:12 AEST

Update

Thank you for your patience while we investigated the appointment slowness problem. Based on our monitoring, the issue now appears to be fully resolved. Please reach out to our support team if you are still experiencing any issues.
Posted Jan 20, 2026 - 14:11 AEST

Investigating

The appointment calendar is currently experiencing intermittent slowness resulting in some error messages, appointments appearing to be missing until the screen is refreshed, and general degradation in the appointments tab. We are investigating this issue and will provide updates on our status page as soon as they are available.
Posted Jan 20, 2026 - 09:33 AEST
This incident affected: Appointment Book.