Multiple Issues
Incident Report for MediRecords
Resolved
This incident has now been resolved. Please contact Support if you are continuing to have errors appear.
Posted Jan 16, 2024 - 22:28 AEDT
Identified
Some customers are experiencing issues with saving consult notes, prescribing medication, invoicing or uploading files. We are investigating this as a priority and will provide an update shortly.
Posted Jan 16, 2024 - 18:57 AEDT
This incident affected: MediRecords.