Experiencing Degraded Performance

Incident Report for MediRecords

Resolved

This incident has been resolved.
Posted Oct 22, 2024 - 16:00 AEDT

Investigating

We are aware of intermittent issues with platform response times impacting some clients. We are actively monitoring performance and will keep you appraised.

We appreciate your patience during this incident.
Posted Oct 22, 2024 - 15:02 AEDT
This incident affected: MediRecords.