Google Chrome: Reports of PDF viewer failing
Incident Report for MediRecords
Resolved
Google has now released version 80.0.3987.132 to the public. Please update your Google Chrome browser to the latest version to resolve this issue.

https://support.google.com/chrome/answer/95414
Posted Mar 04, 2020 - 11:51 AEDT
Identified
A recent Chrome update (80.0.3987.100) introduced a bug impacting Chrome's default PDF viewer. If you're browsing MediRecords on Google Chrome you may experience issues previewing or printing PDF documents from within your Chrome browser. Google has already patched this bug in the latest version (80.0.3987.132) to be released shortly.

If you encounter issues with viewing and printing MediRecords generated PDFs from within your Chrome browser, we recommend you:

1) Save the PDF to your local file
2) Open it in your default PDF viewer (e.g. Adobe Reader https://get.adobe.com/reader/)

Bug Report from Google Chrome: https://bugs.chromium.org/p/chromium/issues/detail?id=1054978
Posted Mar 03, 2020 - 10:54 AEDT
This incident affected: MediRecords.