Degraded performance: System performing slower than usual with reported errors being addressed

Incident Report for MediRecords

Resolved

This issue is now resolved and MediRecords is functioning as expected
Posted May 18, 2023 - 14:59 AEST

Investigating

We are currently investigating the issues affecting Medicords. We will provide updates shortly.
Posted May 18, 2023 - 12:53 AEST
This incident affected: MediRecords.