Status Update – Intermittent Slowness Across the MediRecords Platform

Incident Report for MediRecords

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 14:21 AEST

Investigating

We are currently aware of an issue causing intermittent slowness across the MediRecords platform.

Our internal teams are actively investigating the root cause and working to restore optimal performance as quickly as possible. This issue may result in delayed load times or slower-than-usual responses within the application.

We understand the critical nature of this disruption and apologise for the inconvenience caused. We will continue to provide updates on this page as soon as more information becomes available.

Please reach out to the MediRecords Support Team if you have any questions: support@medirecords.com

Thank you for your patience and understanding.
Posted Jun 20, 2025 - 12:12 AEST
This incident affected: MediRecords.