Slow Response Times
Incident Report for MediRecords
Resolved
This incident has been resolved and we are continuing to monitor the system for any changes.
Posted May 31, 2023 - 14:23 AEST
Identified
Our Engineering team have identified a potential issue and are implementing a solution that is expected to take effect by 2.30pm AEST.
Posted May 31, 2023 - 13:59 AEST
Investigating
MediRecords is investigating reports of some users experiencing slower than usual response times.
Posted May 31, 2023 - 13:43 AEST
This incident affected: MediRecords.