Health Funds missing from Patient Records
Incident Report for MediRecords
Resolved
This incident is now resolved.

We thank you for your patience during this incident.
Posted Mar 22, 2023 - 18:04 AEDT
Investigating
ECLIPSE Health Funds are currently missing from Patient Records which in turn is affecting IMC Claiming.
We are investigating the issue and endeavour to correct this urgently.
We appreciate your patience at this time.
Posted Mar 22, 2023 - 10:55 AEDT
This incident affected: Third Party Components (Medicare).