System Slowness
Incident Report for MediRecords
Resolved
This incident has now been resolved
Posted Jun 30, 2023 - 16:02 AEST
Investigating
We are currently investigating
Posted Jun 30, 2023 - 11:04 AEST
This incident affected: MediRecords.